Sep 9, 2013

RPTools.net Access Issues


We've been having numerous site-related issues over the last couple of weeks.

Category: System
Posted by: Azhrei

First, we had problems with our image gallery at gallery.rptools.net.  In trying to resolve performance issues that caused our hosting provider (HostGator) to shut us down temporarily it was determined that an injection attack had comprised the site.  The short-term solution is to disable the gallery itself until it can be repaired.

Second, HostGator moved our site to new hardware last week and we received a new IP address.  However, unknown to me (!) our DNS was being handled by an external service so it didn't automatically update.  That meant outages for some people depending on when their local DNS caches expired.  (The time-to-live from the external service appears to be 6 hours.)  We believe we have this resolved now as well, although it may take a little longer for subdomains to become active (such as forums.rptools.net).

Last, it appears that HG has difficulty adding additional users/email addresses as "authorized users" in terms of correcting technical issues.  There is no quick fix for this.  My plan is to review their current process and see what can be done on our end to spread the load a bit.  For example, an email alias that is auto-forwarded to multiple people, each of them capable of resolving site-related issues.

My apologies for the recent amount of down time for RPTools.net.  Be assured that we're not going anywhere and we'll be back up and fully operating as soon as possible.  In the mean time, I plan to review both our web site organization as well as the MapTool connectivity requirements so that alternatives are "built-in".  (For example, MapTool currently goes to services.rptools.net in order to register a new server.  I may build a second web site and give MT an alternate location.)

Thanks for sticking with us during this time!